Search
 
 

Display results as :
 


Rechercher Advanced Search

Keywords

18rc  Rt43  wagon  Texas  

Latest topics
» 1973 T89 wagon Coolant Pipe 18r-c engine. Where to find a replacement?
Speedometer Malfunction Question... EmptySun Dec 16, 2018 11:08 am by coleslaw

» ***F/S RT104 O.E. Clutch Pedal Assembly Manual Trans. Swap RT104 ***
Speedometer Malfunction Question... EmptyThu Apr 19, 2018 12:56 pm by whit

» RT8# Clutch / Brake Pedal Assembly
Speedometer Malfunction Question... EmptyTue Apr 17, 2018 12:28 am by osgonRT85

» New corona owner from kauai, Hawaii!
Speedometer Malfunction Question... EmptyWed Apr 04, 2018 5:44 am by Axelmon78

» NEW (original TOYOTA) parts for CORONA
Speedometer Malfunction Question... EmptyWed Apr 04, 2018 1:32 am by mark_II_hardtop

» Need help deciding
Speedometer Malfunction Question... EmptyFri Dec 01, 2017 11:21 pm by Cthree

» 1970 Mark 2 Corona Hardtop Resurrection
Speedometer Malfunction Question... EmptySun Sep 17, 2017 11:02 am by andrewe

» 20r overheating, help!!!!!
Speedometer Malfunction Question... EmptyThu Aug 24, 2017 5:06 am by corona extra

» 72 mk2 mx22 2dr from Cali
Speedometer Malfunction Question... EmptyThu Aug 17, 2017 9:52 pm by RT85CORONA

July 2019
MonTueWedThuFriSatSun
1234567
891011121314
15161718192021
22232425262728
293031    

Calendar Calendar

Affiliates
free forum


Speedometer Malfunction Question...

Go down

Speedometer Malfunction Question... Empty Speedometer Malfunction Question...

Post by justchilin on Mon Jan 14, 2013 3:27 pm

Hey everyone, its a cold ass day here in So.Cal, took my 72 Corona out for a spin and I hear grinding and bouncing of my Speedo. WTF! My speedo had been making funny noises recently but this was nasty. It bounces and goes all the way to the max starting from about 10mph or so. As I drove it, it got better, it didnt start grinding until about 40mph or so. I think as it warms up, it would get better but just reaching out to you all, do I need a new Speedo cable? Never replaced one, do I need to take the dash off or can I get to it under the dash? Anyone had this happen to them? Here is a video of my poor 'Rona...Thanks ahead of time.

justchilin
justchilin

Posts : 117
Join date : 2012-11-11
Age : 37
Location : Simi Valley,CA -SoCal

Back to top Go down

Speedometer Malfunction Question... Empty Re: Speedometer Malfunction Question...

Post by justchilin on Mon Jan 14, 2013 8:56 pm

just a follow-up. Later in the day I drove the car around again, it didnt do the jumping and grinding thing. Could it be that the grease within the speedo cable hardens up with the cold weather causing, somehow, this issue? (im just speculating and not basing this one any knowledge whatsoever,ha) Anyways, there is some cheap ones on the bay but just wanted to see if any of you that live in the cold weather has had this happen to any of your cars. It has gotten down to the low to mid 30's at night here, pretty darn cold for So.Cal, so just wondering. Thanks
justchilin
justchilin

Posts : 117
Join date : 2012-11-11
Age : 37
Location : Simi Valley,CA -SoCal

Back to top Go down

Speedometer Malfunction Question... Empty Re: Speedometer Malfunction Question...

Post by RT85CORONA on Tue Jan 15, 2013 1:27 am

i havent had this happen to me but some grease on the cable and the speedo might help you keep us updated

_________________
1973 Toyota Corona - currently doing complete rebuild frame up
2012 toyota Highlander - polk speakers 2-jl 10w6
RT85CORONA
RT85CORONA
Admin
Admin

Posts : 268
Join date : 2012-07-10
Age : 31
Location : Northern California

http://vintagecorona.forumotion.com

Back to top Go down

Speedometer Malfunction Question... Empty Re: Speedometer Malfunction Question...

Post by Sponsored content


Sponsored content


Back to top Go down

Back to top

- Similar topics

 
Permissions in this forum:
You cannot reply to topics in this forum